Order form not loading

I’m trying to place an order and it shows nothing past MedMamas kieff 99. No submit button, no email, no coupon code area. 🤷‍♀️ I’ve refreshed the site numerous times and still no submit button. Thanks in advance for fixing this.


  • It looks to stop resolving just after “Strains/Loud/Jager”

  • I just checked... not fully loading.

    I checked on my android mobile... not sure of that is a factor.

    I had this issue a few days ago... thread got deleted. Don't know why.

    The problem will resolve itself... has done so in the past....could be worse.

  • We have identified the issue here and we have a fix in process. The site should be working again later today. Sorry for the inconvenience to everyone!

  • Any idea when the order form will be back up?

  • Delete cache then retry. That should work

  • It's working for me now. Anyone out there having a different experience?

  • edited January 2020

    Working for me.

    And then five minutes later it's not.

    Android mobile.

  • @daCabbie I'm sorry to say you're not the only one having this experience right now!

  • Reloading really helps...

    99% of the time it's an operator malfunction.


  • 2/1/20 Is eny 1 having trouble downloading the order form site ? Only brings up part of the site ? Cant order no Vapes or enythg ?

  • Yes I'm having trouble to ? Cant order 0

  • edited February 2020

    The first few times I tried I used safari on iPhone. It doesn’t work anymore for me. I can view the site but when I click on the order form it stops working.. I downloaded Tor browser a while back to surf some deep web stuff and the site works just fine on that platform..

  • If the web site is order page is working ! Go on line Google and that always works!

  • It did work long enough to place an order lol ??, and when I was done ordering, I looked and it wasn't working again ? Got me.

  • I'm experiencing longer than usual payment conformation. That is worse than waiting for a late shipment . It's like tossing a bunch of cash into the air and hoping for the best.
    I'm guessing the dumb ass superbowl is hogging up the internet and making it slow AF.

  • @Thisguy I made an order earlier, medman’s site was a breeze, with Tor of course, it’s nice because I can have the menus pulled up on safari, and the order form on Tor.. anyways Coinbase has always also been a breeze for me.. today it was sluggish. Took a good 2 hours or so to go through with the payment. So I know the “toss the cash” feeling!

  • Order form not working for me

  • I found it dont work neither nomore , if I have the MM site down loaded to front page ect ,for some reason ? Now you have to clear all cookies from crome each time you order ! Then go to order page ,comes up every time then.

  • It's working now. If you can't get it to load up, then hit SHIFT-refresh on your browser. If that doesn't work then you'll have to clear your browser's cache.

  • Order form is still not loading completely this morning. Have tried different browsers and deleted the cache as well.

  • So, I just tried from my laptop and the order form loaded just fine! If you're using your phone and it's not working, try a desktop computer or laptop if you have one. 😉

  • Go to the library.

Sign In or Register to comment.